24SG3 - Display Stuck on CYC Logo

Display Stuck on CYC Logo


Symptoms


When you turn on your kit the Display only shows the CYC Logo.


Possible Causes


This issue may be caused by:


  • The firmware on the controller or display is not up to date.
  • The controller and/ or peripherals are not communicating properly.


Checklist


  1. Unplug the display and the wiring harness and check the connectors at both the display-harness and the controller-harness points.
    *The pins on the connectors need to be inspected carefully as any pins that are bent or have moved from their original position, can cause issues. CYC or an Authorised Reseller may ask you for evidence showing that your connector pins are still in good condition.
  2. Ensure there are no wires that are pinched in or bent flat that could be obstructing the signal or damaging the cables.
    *It's best to check the system with the wiring harness and cables freely moving i.e. not tied onto your bike frame.
  3. Ensure that your battery is fully charged and in good condition.
    *You can use a voltmeter or multimeter to check that your battery is not corrupted.


Troubleshooting Steps


  1. If you have completed the above checklist, proved that your connector pins are in good condition, and you still cannot find a cause for the kit not turning on, confirm the following:
    1. If you have another CYC kit or have sufficient additional spare parts, swap out the display to see if the display works on the other system. You can also swap out the controller and wiring harness respectively. If you can locate the issue by swapping out components, then you can report your findings directly to CYC or an Authorised Reseller to organize a replacement (i.e. you do not need to continue troubleshooting).
      *If you do not have any spare parts, continue to step 2 below.
    2. Do a full sensor check.
      1. Disconnect the torque sensor and test by restarting the display and checking if the display now operates as normal. If the system now operates as normal, your torque sensor needs to be replaced. If there's no change, and the display still gets stuck on the logo screen, reconnect the torque sensor cable and continue troubleshooting. 
      2. Disconnect the motor cable and test by restarting the display and checking if the display now operates as normal. If the system now operates as normal, your motor needs to be replaced. If there's no change, and the display still gets stuck on the logo screen, reconnect the hall sensor (or motor cable) and continue troubleshooting.  
      3. Disconnect the speed sensor and test by restarting the display and checking if the display now operates as normal. If the system now operates as normal, your speed sensor needs to be replaced. If there's no change, and the display still gets stuck on the logo screen, reconnect the speed sensor and continue troubleshooting.   
  2. If all the sensors are checked and the issue persists then do a firmware reflash: See the firmware article here for instructions: ðŸ“„ X1 Stealth Gen 3: Firmware
  3. If the firmware can not be flashed or does not resolve the issue, perform a Display Bypass

WARNING: The below steps should be exercised with care. Mistakes may cause additional issues. You may choose to send your components to CYC or an Authorised Reseller for testing instead.

    1. Unplug the display and short-circuit the B+ & Key-In pins using a Dupont wire. See the diagram below for reference.
    2. Attempt to connect to the CYC Ride Control app.
    3. Lift the rear wheel and press in the throttle.

WARNING: Lift the rear wheel BEFORE attempting to press the throttle as the system will be in the highest assist level by default.


B+ and Key-In pin locations


Dupont wire reference


Solution


1. Replace the display

With the B+ and Key-in pins connected, if you can connect to the Ride Control app and your throttle is outputting power when pressed down, then the display has failed and needs to be replaced.


2. Replace the controller

With the B+ and Key-in pins connected, if you cannot connect to the Ride Control app and your throttle is not outputting any power when pressed down, then it is likely a controller issue. Replace the controller accordingly.


3. Replace torque sensor/ motor/ speed sensors 

If the issue is resolved by disconnecting the sensor then replace that part.


Warranty Information


If the component/s are still within its warranty period and show no signs of physical alteration or damage (such as cut wires), the necessary component/s will be replaced under warranty.